CentOS 官方默认不在对mcrypt模块 进行支持

时间: 2016-03-23 / 分类: centos / 浏览次数: 1,764 views / 0个评论 发表评论

原来CentOS 官方默认不在对mcrypt模块 进行支持,所以必须另想办法折腾了2个小时总算搞定,这里主要使用了Fedora的扩展库,EPEL (Extra Packages for Enterprise Linux)先分享解决过程如下:

第一步:在扩展库中查找rpm包

打开网址: http://mirrors.sohu.com/fedora-epel/6/i386/ 使用 Ctrl+F 搜索关键词“epel-release” 找到当前最新的扩展包发现最新版本为:epel-release-6-7.noarch.rpm

如下截图:

clip_image001

然后执行命令:

[root@ptr228 ~]# rpm -ivh http://mirrors.sohu.com/fedora-epel/6/i386/epel-release-6-7.noarch.rpm

见图:

clip_image002

注意:扩展包得不断更新的,所以需要搜索 “epel-release” 找到正确的版本,否则命令将不能执行成功。

第二步:执行命令:yum update 更行系统 见下图:

执行命令:

[root@ptr228 ~]# yum update

然后就是一段时间的等待了,因为系统会更新到CentOS 最新版本有可能会时间比较长。更新完成后会有Complete! 提示

见下图:

clip_image003

注意这里可能会出错,

Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

处理很简单,修改文件“/etc/yum.repos.d/epel.repo”, 将baseurl的注释取消, mirrorlist注释掉。即可。

第三步:执行命令 yum repolist 查看安装结果

查看是否已经有了 EPEL(Extra Packages for Enterprise Linux) 扩展包,执行命令和结果如下:

执行命令:

[root@ptr228 ~]# yum repolist

见图:

clip_image004

如果发现了如图中所示的epel 说明已经安装成功,可以继续执行了。

第四步:执行命令: yum install php-mcrypt 安装mcrypt扩展包

执行命令:

[root@ptr228 ~]# yum install php-mcrypt

见图:

clip_image005

可以看到已经可以安装了,输入 y 继续安装。

第五步:重启apache是扩展生效

执行命令:

[root@ptr228 ~]# service httpd restart

见图:

clip_image006

再打开 PHPMyadmin 红色的错误提示已经没有。

发表评论

你必须 登录后 才能留言!