WordPress升级需要FTP信息的解决办法

时间: 2011-02-06 / 分类: wordpress / 浏览次数: 2,608 views / 0个评论 发表评论

在升级主题,安装主题,升级插件,安装插件时都有可能遇到需要填写FTP信息,更可气的是往往填写了还是不能安装或者升级。

打开wp-config.php,在最后面添加如下几行代码:

/** Override default file permissions */
if(is_admin()) {
add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
define( 'FS_CHMOD_DIR', 0751 );
}

这个方法对WP带来的安全性还有待考虑,不过暂时是把问题解决了。

发表评论

你必须 登录后 才能留言!